Aanvragen SSL certificaat mislukt: Authorization for the domain failed

Symptomen

De website waarvoor je een SSL certificaat probeert aan te vragen is net nieuw geregistreerd of verhuisd vanaf een andere provider en bij het aanvragen van het certificaat (Gratis SSL certificaat van Let's Encrypt aanvragen) krijg je één van de volgende meldingen

Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz-v3/6265875139. Details: Type: urn:ietf:params:acme:error:dns Status: 400 Detail: DNS problem: SERVFAIL looking up A for example.com - the domain's nameservers may be malfunctioning

Of

Error: Could not issue a Let's Encrypt SSL/TLS certificate for example.com. Your domain in Plesk is hosted on the IP address(es): , but the DNS challenge used another IP address: 203.0.113.3. Please check the actual DNS zone of your domain and make sure that the IP addresses in the DNS zone and for the hosting are the same. Details Invalid response from https://acme-v01.api.letsencrypt.org/acme/authz/5B8TL2C3swolx5XyBM871hgUwlQlx_JBAMfuOB3pqOQ. Details: Type: urn:acme:error:unauthorized Status: 403 Detail: Invalid response from http://example.org/.well-known/acme-challenge/PQkwA_59YpHBN7kC2NcUHkaBX2Z8F1GI0QEnxnP81k8: "

Oorzaak

  • Het domein kan nog niet worden geresolved door de DNS servers of er bestaat geen A-record in de DNS van het domein.

Let op: wanneer een domein net nieuw geregistreerd is of net verhuist, duurt het tot maximaal 4 uur voordat alle DNS servers het domein naar je hosting bij ons verwijzen. Controleer of het domein aanwezig is bij de DNS Zone (Domein toevoegen aan DNS Zone) en wacht deze tijd even af en vraag het SSL certificaat vervolgens opnieuw aan.

Oplossing

Zorg dat het A record van het domein naar onze server verwijst. Als eerste gaan we kijken wat het ip adres is van de server waar het Webhosting Pakket op staat en daarna gaan we de DNS instellingen controleren.

Server ip van webhosting pakket

  1. Login op Mijn Cloud86 (Mijn Cloud86: Inloggen en 2FA)
  2. Klik in het linkermenu op Mijn diensten
  3. Klik vervolgens op de 3 stipjes achter het webhostingpakket waar het domein onder geregistreerd staat en op Bekijk details.
    Mijn Cloud86: Mijn diensten, bekijk details (NL).png
  4. Scroll naar onderen en kijk bij Extra Informatie, hier staat het ipadres van de server waar het Webhosting Pakket actief is.Mijn Cloud86: Mijn dienst, server, ip adres (NL).png

DNS Instellingen controleren

Met het ip adres wat wij hierboven gevonden hebben (in ons voorbeeld: 45.82.191.14, vervang dit met het ip adres van jouw Webhosting Pakket), kunnen wij controleren of het A record ook naar onze server verwijst.

  1. In Mijn Cloud86, klik in het linkermenu op Domeinnamen en DNS beheren. Controleer of het domein is toegevoegd aan het juiste webhosting pakket. Zo niet, volg Domein toevoegen aan DNS Zone.
  2. Als het domein er tussen staat klik op het potlood-icoon (dit is de knop Bewerk DNS zone). En controleer of het A record met de naam @ naar het ip adres van hierboven verwijst.
  3. Als bovenstaande allemaal goed, controleer dan of de DNS aanpassingen goed gepropageerd worden. Dit kun je bijvoorbeeld doen met de website https://dnschecker.org. Wanneer alle DNS servers groene vinkjes laten zien én het juiste IP adres van de server wordt vermeld, kun je het SSL certificaat in Plesk opnieuw aanvragen (Gratis SSL certificaat van Let's Encrypt aanvragen)

Mocht je er niet helemaal uit komen kun je onze supportdesk altijd bereiken per mail support@cloud86.io en op werkdagen van 10:00 tot 16:00 kun je ons ook bereiken per telefoon en via de chat in Mijn Cloud86 omgeving.