Impossibile emettere un certificato SSL/TLS Let’s Encrypt. L’autorizzazione per il dominio non è riuscita.


Sintomi

Il sito per cui stai cercando di richiedere un certificato SSL è stato appena registrato oppure è stato trasferito da un altro provider e, nel richiedere il certificato, compare uno dei seguenti messaggi:

Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz/1618170247/701603117786
Details:
Type: urn:ietf:params:acme:error:dns
Status: 400
Detail: DNS problem: NXDOMAIN looking up A for cloud86example.it - check that a DNS record exists for this domain; DNS problem: NXDOMAIN looking up AAAA for cloud86example.it - check that a DNS record exists for this domain

Oppure questo messaggio:

Vai a http://cloud86example.com/.well-known/acme-challenge/lmdrncNo4SfL_exHIisTeSPqxfq9Yg9ZOJh0-SlmdRI
e controlla se l'URL del token di autorizzazione accetta richieste esterne. In alternativa, usa un servizio di terze parti come letsdebug.net per verificare che cloud86example.com rispetti i requisiti di Let's Encrypt.
In caso affermativo, prova a richiedere nuovamente il certificato. Se il token non è disponibile, potrebbe esserci un problema con la tua configurazione DNS.
Il tuo dominio in Plesk è ospitato in uno o più dei seguenti indirizzi IP: 45.82.191.14 2a0e:7280:0:191:14:777:0:1, ma la sfida DNS ha utilizzato un altro IP: 45.82.191.123.
Assicurati che gli indirizzi IP specificati nella zona DNS del dominio corrispondano a quelli in cui è ospitato il dominio stesso, e che la porta 80 sia aperta e raggiungibile nei firewall interni ed esterni.
Se non ottieni risultati o non riesci a identificare problemi con la tua configurazione DNS, leggi questo articolo della KB per trovare una possibile soluzione."


Causa

  • Il dominio non può ancora essere “risolto” dai DNS o non esiste un record A nella zona DNS del dominio. 

Nota: quando un dominio è appena registrato o appena trasferito, possono essere necessarie fino a 4 ore prima che tutti i server DNS puntino il dominio verso il tuo hosting presso Cloud86. Controlla che il dominio sia presente nella zona DNS, attendi il tempo necessario e poi riprova a chiedere il certificato SSL.


Soluzione

Verifica che l’A record del dominio punti al nostro server. Prima individuiamo l’indirizzo IP del server su cui si trova il piano di Web Hosting, poi controlleremo le impostazioni DNS.

IP del server del piano di Web Hosting 

  1. Accedi al tuo profilo Il mio Cloud86
  2. Clicca nel menu a sinistra su I miei servizi
  3. Poi clicca sui 3 puntini accanto al piano di web hosting a cui è associato il dominio e seleziona Visualizza dettagli. 
    IT My Cloud86_ My Services, view details.png.png
  4. Scorri verso il basso e alla voce Informazioni Hosting troverai l’indirizzo IP del server su cui è attivo il piano di web hosting. 
    IT My Cloud86_ My Service, server name and ip.png

Controllare le impostazioni DNS

Con l’indirizzo IP trovato sopra (nell’esempio: 45.82.191.14, da sostituire con l’IP del tuo piano di Web Hosting, possiamo verificare che l’A record punti correttamente verso il nostro server.

  1. All’interno del tuo profilo Il mio Cloud86, clicca nel menu a sinistra su Domini e poi Gestione DNS. Controlla che il dominio sia stato aggiunto al corretto piano di web hosting. In caso contrario, leggi e applica le indicazioni dell’articolo Aggiungere un dominio alla zona DNS.
  2. Se il dominio è presente, clicca sull’icona della matita (Modifica zona DNS) e verifica che l’A record con nome @ punti all’indirizzo IP di cui sopra.
  3. Se tutto è corretto, verifica che le modifiche DNS siano state propagate. Puoi farlo tramite il sito https://dnschecker.org. Quando tutti i server DNS mostrano un segno di spunta verde e l’indirizzo IP corretto, puoi riprovare a richiedere il certificato SSL attraverso il pannello di controllo Plesk. 

Se hai bisogno di aiuto, puoi sempre contattare il nostro supporto via email all’indirizzo support@cloud86.io. Nei giorni feriali, dalle 9:00 alle 16:00 (CET), siamo disponibili anche telefonicamente e tramite la chat localizzata nella dashboard Il mio Cloud86.